Muzes Status - Muzes Discover Website is down – Incident details
Report an issue
Muzes
Report an issue
Muzes
Dark mode
All systems operational
Muzes Discover Website is down
Resolved
Major outage
Started 10 days ago
Lasted 2 days
Updates
Resolved
June 25, 2025 at 7:58 AM
Resolved
June 25, 2025 at 7:58 AM
is back up. This incident was automatically resolved by Instatus monitoring.
Investigating
June 23, 2025 at 1:42 AM
Investigating
June 23, 2025 at 1:42 AM
is down at the moment. This incident was automatically created by Instatus monitoring.