Muzes Status - Muzes Discover Website is down – Incident details
Report an issue
Muzes
Report an issue
Muzes
Dark mode
All systems operational
Muzes Discover Website is down
Resolved
Major outage
Started 18 days ago
Lasted 11 minutes
Updates
Resolved
June 14, 2025 at 3:57 PM
Resolved
June 14, 2025 at 3:57 PM
is back up. This incident was automatically resolved by Instatus monitoring.
Investigating
June 14, 2025 at 3:47 PM
Investigating
June 14, 2025 at 3:47 PM
is down at the moment. This incident was automatically created by Instatus monitoring.