Muzes Status - Muzes Website is down – Incident details
Report an issue
Muzes
Report an issue
Muzes
Dark mode
Experiencing partial outage
Muzes Website is down
Resolved
Major outage
Started 28 days ago
Lasted 10 minutes
Updates
Resolved
February 27, 2026 at 7:10 PM
Resolved
February 27, 2026 at 7:10 PM
is back up. This incident was automatically resolved by Instatus monitoring.
Investigating
February 27, 2026 at 7:00 PM
Investigating
February 27, 2026 at 7:00 PM
is down at the moment. This incident was automatically created by Instatus monitoring.